import re
regex = re.compile(r"#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("# Mandatory parameter\n"
"#EPCDatabase/EPCdatabase.param/epc.db.user=\n"
"# Mandatory parameter\n"
"#EPCDatabase/EPCdatabase.param/epc.db.password=\n"
"# Mandatory parameter")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")