$re = '/#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$/im';
$str = '# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.user=
# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.password=
# Mandatory parameter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);