// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$").unwrap();
let string = "# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.user=
# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.password=
# Mandatory parameter";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}