package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)#EPCDatabase\/EPCdatabase.param\/epc.db.user=.*$`)
var str = `# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.user=
# Mandatory parameter
#EPCDatabase/EPCdatabase.param/epc.db.password=
# Mandatory parameter`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}