#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\[[^\]]+\](?(?=\s*;)\s*;.*|$)"
Local $sString = "[asd]" & @CRLF & _
"[asd];" & @CRLF & _
"[asd] ;" & @CRLF & _
"[asd]asd" & @CRLF & _
"[asdf];asd" & @CRLF & _
"[some;thing]" & @CRLF & _
" - Valid, with capture group some;thing" & @CRLF & _
"[something]" & @CRLF & _
" - Valid, with capture group something" & @CRLF & _
" [something]" & @CRLF & _
" - Invalid, does not begin with " & @CRLF & _
"" & @CRLF & _
"[something] ;ojasodj" & @CRLF & _
" - Valid, capture group something" & @CRLF & _
"" & @CRLF & _
"[something] " & @CRLF & _
"- Invalid, space after ] without a ; present" & @CRLF & _
"" & @CRLF & _
"[something];" & @CRLF & _
" - Valid, capture group something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")