using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[[^\]]+\](?(?=\s*;)\s*;.*|$)";
string input = @"[asd]
[asd];
[asd] ;
[asd]asd
[asdf];asd
[some;thing]
- Valid, with capture group some;thing
[something]
- Valid, with capture group something
[something]
- Invalid, does not begin with
[something] ;ojasodj
- Valid, capture group something
[something]
- Invalid, space after ] without a ; present
[something];
- Valid, capture group something";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}