use strict;
my $str = '[asd]
[asd];
[asd] ;
[asd]asd
[asdf];asd
[some;thing]
- Valid, with capture group some;thing
[something]
- Valid, with capture group something
[something]
- Invalid, does not begin with
[something] ;ojasodj
- Valid, capture group something
[something]
- Invalid, space after ] without a ; present
[something];
- Valid, capture group something';
my $regex = qr/^\[[^\]]+\](?(?=\s*;)\s*;.*|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}