import Foundation
let pattern = #"^\[[^\]]+\](?(?=\s*;)\s*;.*|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[asd]
[asd];
[asd] ;
[asd]asd
[asdf];asd
[some;thing]
- Valid, with capture group some;thing
[something]
- Valid, with capture group something
[something]
- Invalid, does not begin with
[something] ;ojasodj
- Valid, capture group something
[something]
- Invalid, space after ] without a ; present
[something];
- Valid, capture group something
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)