import re
regex = re.compile(r"^\[[^\]]+\](?(?=\s*;)\s*;.*|$)", flags=re.MULTILINE)
test_str = ("[asd]\n"
"[asd];\n"
"[asd] ;\n"
"[asd]asd\n"
"[asdf];asd\n"
"[some;thing]\n"
" - Valid, with capture group some;thing\n"
"[something]\n"
" - Valid, with capture group something\n"
" [something]\n"
" - Invalid, does not begin with \n\n"
"[something] ;ojasodj\n"
" - Valid, capture group something\n\n"
"[something] \n"
"- Invalid, space after ] without a ; present\n\n"
"[something];\n"
" - Valid, capture group something")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")