const regex = /^\[[^\]]+\](?(?=\s*;)\s*;.*|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[[^\\]]+\\](?(?=\\s*;)\\s*;.*|$)', 'gm')
const str = `[asd]
[asd];
[asd] ;
[asd]asd
[asdf];asd
[some;thing]
- Valid, with capture group some;thing
[something]
- Valid, with capture group something
[something]
- Invalid, does not begin with
[something] ;ojasodj
- Valid, capture group something
[something]
- Invalid, space after ] without a ; present
[something];
- Valid, capture group something`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}