$re = '/^\[[^\]]+\](?(?=\s*;)\s*;.*|$)/m';
$str = '[asd]
[asd];
[asd] ;
[asd]asd
[asdf];asd
[some;thing]
- Valid, with capture group some;thing
[something]
- Valid, with capture group something
[something]
- Invalid, does not begin with
[something] ;ojasodj
- Valid, capture group something
[something]
- Invalid, space after ] without a ; present
[something];
- Valid, capture group something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);