using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(([0-9])\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))";
string input = @"000000001
000000009
333333333
777777775
999999990
999999999
123123123
123456780
123456785
123456789
123654789
102030405
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}