import re
regex = re.compile(r"(?!(([0-9])\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))", flags=re.MULTILINE)
test_str = ("000000001\n"
"000000009\n"
"333333333\n"
"777777775\n"
"999999990\n"
"999999999\n"
"123123123\n"
"123456780\n"
"123456785\n"
"123456789\n"
"123654789\n"
"102030405\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")