import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(([0-9])\\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))";
final String string = "000000001\n"
+ "000000009\n"
+ "333333333\n"
+ "777777775\n"
+ "999999990\n"
+ "999999999\n"
+ "123123123\n"
+ "123456780\n"
+ "123456785\n"
+ "123456789\n"
+ "123654789\n"
+ "102030405\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}