use strict;
my $str = '000000001
000000009
333333333
777777775
999999990
999999999
123123123
123456780
123456785
123456789
123654789
102030405
';
my $regex = qr/(?!(([0-9])\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}