const regex = /(?!(([0-9])\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(([0-9])\\1{7}([0-9]){1}|12345678([0-9]){1}|(123){3,9}))', 'gm')
const str = `000000001
000000009
333333333
777777775
999999990
999999999
123123123
123456780
123456785
123456789
123654789
102030405
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}