#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)§§\s*((?:Satz|Abs\.|Nr\.|\d+[a-z]?|und|[\s,])+)(?<=\w)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren" & @CRLF & _
" From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be " & @CRLF & _
"Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu" & @CRLF & _
" Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")