import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "§§\\s*((?:Satz|Abs\\.|Nr\\.|\\d+[a-z]?|und|[\\s,])+)(?<=\\w)";
final String string = "\n\n"
+ "Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren\n"
+ " From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be \n"
+ "Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu\n"
+ " Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}