const regex = new RegExp('§§\\s*((?:Satz|Abs\\.|Nr\\.|\\d+[a-z]?|und|[\\s,])+)(?<=\\w)', 'gm')
const str = `
Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren
From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be
Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu
Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}