$re = '/§§\s*((?:Satz|Abs\.|Nr\.|\d+[a-z]?|und|[\s,])+)(?<=\w)/m';
$str = '
Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren
From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be
Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu
Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);