using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"§§\s*((?:Satz|Abs\.|Nr\.|\d+[a-z]?|und|[\s,])+)(?<=\w)";
string input = @"
Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren
From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be
Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu
Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}