import Foundation
let pattern = #"§§\s*((?:Satz|Abs\.|Nr\.|\d+[a-z]?|und|[\s,])+)(?<=\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Die Anzahl der §§ 12 Abs. 5, 13a, 14 Satz 1 und 8 variieren
From this string I want to get the part 12 Abs. 5, 13a, 14 Satz 1 und 8. The string could also be
Für die §§ 15a, 18 Abs. 5, 21 und 23 Satz 3 trifft dies nicht zu
Here I want to get 15a, 18 Abs. 5, 21 und 23 Satz 3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)