using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\s*""dependencies"":\s*{\s*$";
string input = @"{
""name"": ""suiftly.io"",
""version"": ""0.1.0"",
""description"": ""Suiftly CDN Services"",
""license"": ""Apache License 2.0"",
""type"": ""module"",
""dependencies"": {
""@typescript-eslint/eslint-plugin"": ""^5.12.0""
},
""devDependencies"": {
""debug"": ""4.4.0""
},
""optionalDependencies"": {
""async"": ""3.2.6""
},
""packageManager"": ""yarn@3.8.7""
}
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}