// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\s*"dependencies":\s*{\s*$"#).unwrap();
let string = "{
\"name\": \"suiftly.io\",
\"version\": \"0.1.0\",
\"description\": \"Suiftly CDN Services\",
\"license\": \"Apache License 2.0\",
\"type\": \"module\",
\"dependencies\": {
\"@typescript-eslint/eslint-plugin\": \"^5.12.0\"
},
\"devDependencies\": {
\"debug\": \"4.4.0\"
},
\"optionalDependencies\": {
\"async\": \"3.2.6\"
},
\"packageManager\": \"yarn@3.8.7\"
}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}