use strict;
my $str = '{
"name": "suiftly.io",
"version": "0.1.0",
"description": "Suiftly CDN Services",
"license": "Apache License 2.0",
"type": "module",
"dependencies": {
"@typescript-eslint/eslint-plugin": "^5.12.0"
},
"devDependencies": {
"debug": "4.4.0"
},
"optionalDependencies": {
"async": "3.2.6"
},
"packageManager": "yarn@3.8.7"
}
';
my $regex = qr`(?m)^\s*"dependencies":\s*{\s*$`p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}