import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^\\s*\"dependencies\":\\s*\\{\\s*$";
final String string = "{\n"
+ " \"name\": \"suiftly.io\",\n"
+ " \"version\": \"0.1.0\",\n"
+ " \"description\": \"Suiftly CDN Services\",\n"
+ " \"license\": \"Apache License 2.0\",\n"
+ " \"type\": \"module\",\n"
+ " \"dependencies\": {\n"
+ " \"@typescript-eslint/eslint-plugin\": \"^5.12.0\"\n"
+ " },\n"
+ " \"devDependencies\": {\n"
+ " \"debug\": \"4.4.0\"\n"
+ " },\n"
+ " \"optionalDependencies\": {\n"
+ " \"async\": \"3.2.6\"\n"
+ " },\n"
+ " \"packageManager\": \"yarn@3.8.7\"\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}