import Foundation
let pattern = #"(?m)^\s*"dependencies":\s*{\s*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"name": "suiftly.io",
"version": "0.1.0",
"description": "Suiftly CDN Services",
"license": "Apache License 2.0",
"type": "module",
"dependencies": {
"@typescript-eslint/eslint-plugin": "^5.12.0"
},
"devDependencies": {
"debug": "4.4.0"
},
"optionalDependencies": {
"async": "3.2.6"
},
"packageManager": "yarn@3.8.7"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}