package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*"dependencies":\s*{\s*$`)
var str = `{
"name": "suiftly.io",
"version": "0.1.0",
"description": "Suiftly CDN Services",
"license": "Apache License 2.0",
"type": "module",
"dependencies": {
"@typescript-eslint/eslint-plugin": "^5.12.0"
},
"devDependencies": {
"debug": "4.4.0"
},
"optionalDependencies": {
"async": "3.2.6"
},
"packageManager": "yarn@3.8.7"
}
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}