const regex = new RegExp('(?m)^\\s*"dependencies":\\s*{\\s*$', '')
const str = `{
"name": "suiftly.io",
"version": "0.1.0",
"description": "Suiftly CDN Services",
"license": "Apache License 2.0",
"type": "module",
"dependencies": {
"@typescript-eslint/eslint-plugin": "^5.12.0"
},
"devDependencies": {
"debug": "4.4.0"
},
"optionalDependencies": {
"async": "3.2.6"
},
"packageManager": "yarn@3.8.7"
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}