#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)information\/([0-9]{4})\/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{1,})\/?$"
Local $sString = "http://single.test/information/2024/03/25/1867/" & @CRLF & _
"http://single.test/information/2024/03/25/1869/" & @CRLF & _
"http://single.test/information/2024/03/25/169/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")