$re = '/information\/([0-9]{4})\/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{1,})\/?$/m';
$str = 'http://single.test/information/2024/03/25/1867/
http://single.test/information/2024/03/25/1869/
http://single.test/information/2024/03/25/169/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);