import re
regex = re.compile(r"information\/([0-9]{4})\/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{1,})\/?$", flags=re.MULTILINE)
test_str = ("http://single.test/information/2024/03/25/1867/\n"
"http://single.test/information/2024/03/25/1869/\n"
"http://single.test/information/2024/03/25/169/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")