// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)information\/([0-9]{4})\/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{1,})\/?$").unwrap();
let string = "http://single.test/information/2024/03/25/1867/
http://single.test/information/2024/03/25/1869/
http://single.test/information/2024/03/25/169/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}