package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)information\/([0-9]{4})\/([0-9]{1,2})\/([0-9]{1,2})\/([0-9]{1,})\/?$`)
var str = `http://single.test/information/2024/03/25/1867/
http://single.test/information/2024/03/25/1869/
http://single.test/information/2024/03/25/169/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}