# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<<([-\w ]+)#_/$1/gm;t' <<< "<<Start words#_ I <<love#_ kind <<man>>, <<john#_ <<kind man>> is really <<great>> <<end words#_ \";"