re = /<<([-\w ]+)#_/m
str = '<<Start words#_ I <<love#_ kind <<man>>, <<john#_ <<kind man>> is really <<great>> <<end words#_ ";'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result