package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<<([-\w ]+)#_`)
var str = `<<Start words#_ I <<love#_ kind <<man>>, <<john#_ <<kind man>> is really <<great>> <<end words#_ ";`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}