const regex = /<<([-\w ]+)#_/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<<([-\\w ]+)#_', 'gm')
const str = `<<Start words#_ I <<love#_ kind <<man>>, <<john#_ <<kind man>> is really <<great>> <<end words#_ ";`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);