using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<<([-\w ]+)#_";
string substitution = @"$1";
string input = @"<<Start words#_ I <<love#_ kind <<man>>, <<john#_ <<kind man>> is really <<great>> <<end words#_ "";";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}