const regex = /&(?!(?:#\d+|#x[0-9a-f]+|\w+);)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&(?!(?:#\\d+|#x[0-9a-f]+|\\w+);)', 'gmi')
const str = `{
ᾮ
'
&`;
const subst = `&`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);