use strict;
my $str = '{
ᾮ
'
&';
my $regex = qr/&(?!(?:#\d+|#x[0-9a-f]+|\w+);)/mip;
my $subst = '&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";