$re = '/&(?!(?:#\d+|#x[0-9a-f]+|\w+);)/mi';
$str = '{
ᾮ
'
&';
$subst = "&";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;