import re
regex = re.compile(r"&(?!(?:#\d+|#x[0-9a-f]+|\w+);)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("{\n"
"ᾮ\n"
"'\n"
"&")
subst = "&"
result = regex.sub(subst, test_str)
if result:
print(result)