import Foundation
let pattern = ##"&(?!(?:#\d+|#x[0-9a-f]+|\w+);)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
{
ᾮ
'
&
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"&"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)