#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\s+(\S+\.cpp)\s.*(?:\r?\n(?![01]\r?$).*)*\r?\n([10]+)\r?$"
Local $sString = "123 stringOfFilePathandName.cpp string 013" & @CRLF & _
"...not needed text..." & @CRLF & _
"...not needed text..." & @CRLF & _
"0" & @CRLF & _
"---------------------------------" & @CRLF & _
"56 stringOfFilePathandName2.cpp string 8756" & @CRLF & _
"...not needed text..." & @CRLF & _
"...not needed text..." & @CRLF & _
"1" & @CRLF & _
"---------------------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")