import re
regex = re.compile(r"^\d+\s+(\S+\.cpp)\s.*(?:\r?\n(?![01]\r?$).*)*\r?\n([10]+)\r?$", flags=re.MULTILINE)
test_str = ("123 stringOfFilePathandName.cpp string 013\n"
"...not needed text...\n"
"...not needed text...\n"
"0\n"
"---------------------------------\n"
"56 stringOfFilePathandName2.cpp string 8756\n"
"...not needed text...\n"
"...not needed text...\n"
"1\n"
"---------------------------------")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")