const regex = new RegExp('^\\d+\\s+(\\S+\\.cpp)\\s.*(?:\\r?\\n(?![01]\\r?$).*)*\\r?\\n([10]+)\\r?$', 'gm')
const str = `123 stringOfFilePathandName.cpp string 013
...not needed text...
...not needed text...
0
---------------------------------
56 stringOfFilePathandName2.cpp string 8756
...not needed text...
...not needed text...
1
---------------------------------`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}