import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\s+(\\S+\\.cpp)\\s.*(?:\\r?\\n(?![01]\\r?$).*)*\\r?\\n([10]+)\\r?$";
final String string = "123 stringOfFilePathandName.cpp string 013\n"
+ "...not needed text...\n"
+ "...not needed text...\n"
+ "0\n"
+ "---------------------------------\n"
+ "56 stringOfFilePathandName2.cpp string 8756\n"
+ "...not needed text...\n"
+ "...not needed text...\n"
+ "1\n"
+ "---------------------------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}