use strict;
my $str = '123 stringOfFilePathandName.cpp string 013
...not needed text...
...not needed text...
0
---------------------------------
56 stringOfFilePathandName2.cpp string 8756
...not needed text...
...not needed text...
1
---------------------------------';
my $regex = qr/^\d+\s+(\S+\.cpp)\s.*(?:\r?\n(?![01]\r?$).*)*\r?\n([10]+)\r?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}