$re = '/^\d+\s+(\S+\.cpp)\s.*(?:\r?\n(?![01]\r?$).*)*\r?\n([10]+)\r?$/m';
$str = '123 stringOfFilePathandName.cpp string 013
...not needed text...
...not needed text...
0
---------------------------------
56 stringOfFilePathandName2.cpp string 8756
...not needed text...
...not needed text...
1
---------------------------------';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);